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Department of Tnformation Techmnology

Institute’s Vision

To be a world-class institute and a front runner in the educational and socio-economic development of the

nation by providing high-quality technical education to students from all sections of society.

Institute’s Mission

To provide superior learning experiences in a caring and conducive environment so as to empower students

to be successful in life and contribute positively to society

Department’s Vision

To develop competent, skilled, self-disciplined, and ethically sound IT engineers with a professional attitude
to match global standards.

Department’s Mission

M1: To employ innovative teaching techniques and provide experiential knowledge to create proficient and
responsible IT professionals.

M2: To provide sufficient research opportunities and acquaint students with recent trends in industry.

M3: To enhance creativity and entrepreneurial approach to contribute positively to society with lifelong
learning and commitment to professional ethics.

Program Educational Objectives (PEQO’s)

PEO1: To expose students to a strong foundation in the field of Information Technology for creating
proficient and responsible IT Professionals.

PEO2: To prepare competent IT Engineers as per global career requirements with the ability to engage in
life-long learning.

PEO3: To equip students to gain proficiency in recognizing and understanding the social. cultural. ethical.
global, and environmental responsibilities of a professional engineer and the need for sustainable
development.

PEO4: To encourage students to develop life skills and gain interest in research. entrepreneurship. and
higher studies in the field of Information Technology.

Program Specific Qutcomes (PSO’s)

PSO1: Students will be able to apply the knowledge of Information Technology to Define. Analvze. Design.
Test, and Integrate subsystems to provide domain-specitic IT solutions for real-world problems.
PSO2: Students will be able to apply innovative tools and techniques in the field of Information Security.

Data Analytics, Artificial Intelligence, Cloud Computing. and Information Retrieval.
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Program Qutcomes (PO’s)

PO1: Engineering knowledge: Apply the knowledge of mathematics, science, engineering fundamentals,
and an engineering specialization to the solution of complex engineering problems.

PO2: Problem analysis: Identify, formulate, review research literature, and analyze complex engineering
problems reaching substantiated conclusions using first principles of mathematics, natural sciences, and
engineering sciences.

PO3: Design/development of solutions: Design solutions for complex engineering problems and design
System components or processes that meet the specified needs with appropriate consideration for public
health and safety, and the cultural, societal, and environmental considerations.

PO4: Conduct investigations of complex problems: Use research-based knowledge and rescarch methods
including design of experiments, analysis, and interpretation of data. and synthesis of the information to
provide valid conclusions.

POS: Modern tool usage: Create, select, and apply appropriate techniques. resources. and modern
engineering and IT tools including prediction and modeling to complex enginecring activities with an
understanding of the limitations.

PO6: The engineer and society: Apply reasoning informed by the contextual knowledge 1o assess socictal.
health, safety, legal and cultural issues, and the consequent responsibilities relevant to the professional
engineering practice.

PO7: Environment and sustainabitity: Understand the impact of the professional engincering solutions in
socictal and environmental contexts, and demonstrate the knowledge of. and nced for sustainable
development.

PO8: Ethics: Apply ethical principles and commit to professional ethics and responsibilities and norms of
‘ the engineering practice.

PO9Y: Individual and teamwork: Function effectively as an individual. and as a member or leader in
diverse teams, and in multidisciplinary settings.

PO10: Communication: Communicate effectively on complex engineering activities with the engineering
community and with society at large, such as being able to comprehend and write effective reports and
design documentation, make effective presentations, and give and receive clear instructions

PO11: Project management and finance: Demonstrate knowledge and understanding of the engineering
and management principles and apply these to one’s own work, as a member and leader in a team. to manage
projects and in multidisciplinary environments.

PO12: Life-long learning: Recognize the need for and have the preparation and abilin

independent and life-long learning in the broadest context of technological change
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Experiment 1

Title of the Experiment: Installing Flutter Environment and Creating Hello World App

Date of the Experiment: 06/01/2022
Date of Submission:

Aim:
Flutter SDK
Software Requirements:

e Android Studio
e Android Emulator

A) Installation and Configuration of Flutter Environment.

Install the Flutter SDK

Step 1: Download the installation bundle of the Flutter Software Development Kit for windows.
To download Flutter SDK, Go to its official website https://docs.flutter.dev/get-

started/install ,you will get the following screen.
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@ Note: Are you on Chrome 0S?
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Step 2: Next, to download the latest Flutter SDK, click on the Windows icon. Here, you
willfind the download link for SDK.

Step 3: When your download is complete, extract the zip file and place it in the desired
installation folder or location, for example, C: /Flutter.

Step 4: To run the Flutter command in regular windows console, you need to update the
systempath to include the flutter bin directory. The following steps are required to do this:

Step 4.1: Go to MyComputer properties -> advanced tab -> environment variables. You
will getthe following screen.
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Step 4.3: In the above window, click on New->write path of Flutter bin folder in variable value -
> ok -> ok -> ok.

Step 5: Now, run the $ flutter command in command prompt.

Hicrosoft windows [Version 18.8.12842.1415]
{c) Microsoft Corporation. All rights resecved.

:\Users\jélpa)ﬂu:te‘r
nage your Flutter agp davelc;

oxmen comzands:
flutter ‘create <oltput directo &
Create B new Flutter groject he specified directery.

flutter run [
Run ycur Flutter applicaticn on an attached device or in an emulator.

ge: flutter <cemmand> [argument

1cbal cptions:

h-"flutter doct z itior diagnostic inforzati
to force varbose logging those cases.)
Target davica i nan2 {prafixas allowed).
Reports the version of this tool.
oress anaiytics reporting n this command runs.

mplaticn setup scripts.
h Fluttev channels.

do:tor‘ n m:r-zaticn a:o-
douwngrade ngrade Flutter to tha last active
precache Populate the Flutier u.c.l s cache of
upgrade Upgrade ycur ccpy of

Build an execu

Jelete the build/ "‘d

Creata a new Flutter pro; 5

Run integration tests for the project on an attached device or emulatop.
Format cne or more Dart files. 3

Now, run the $ flutter doctor command. This command checks for all the requirements
ofFlutLer app development and displays a report of the status of your Flutter mstallat]on

jalpa>flutter doctcr
% .n f}.u

) Android devices
% Unable tc locate Android SUK
Install Android Studio frcm: https://developer.android.com/studio/index.html
On First launch it will assist you in installing the Android SOK components.
{or visit https://flutter. /docs/get-started/install/windows#android-setup for detailed instructions).
If the Android SDK has been installed to a custom location, please use
“flutter config --android-sdk”™ to update to that location.

* cmdline-tools com 3
Run " path/to/sdkmana cnjlme teols;latest™
See https://developer.android. rand-line for more details.
Android license status unknown.
in ~flutter doctor --android-licenses’ to accept the SDX licenses.
Se //Flutt;r dev/docs/get-started/install doxs#android-setup for more details.

Cc»n:‘.tad vence (Z available)

¢ Doctor fcund issues in 1 categery.
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Step 6: When you run the above command, it will analyze the system and show its report, as
shown in the below image. Here, you will find the details of all missing tools, which required to
run Flutter as well as the development tools that are available but not connected with the

device.

Step 7: Install the Android SDK. If the flutter doctor command does not find the Android SDK
tool in your system, then you need first to install the Android Studio IDE. To install Android

Studio IDE, do the following steps.

Step 7.1: Download the latest Android Studio executable or zip file from the official site.

Step 7.2: When the download is complete, open the .exe file and run it. You will get the
following dialog box.

Android Studic Setup =

Welcome to Android Studio Setup

Android
Studio

Cance

«Res 4

olleoe(o{ Engineerin
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Android Studic Sstup =

installation Complete

Setup was completed successfully,

Completed

Show details

MHext > _,3

Step 7.4: In the above screen, click Next-> Finish. Once the Finish button is clicked, you need
tochoose the 'Don't import Settings option’ and click OK. It will start the Android Studio.
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Step 7.5 run the $ flutter doctor command and Run flutter doctor --android-licenses command.
A -

Czmmang Frempt

.7 Special Terms for Pre-Release Materials. If so in:icate: in the descripticn of the Evaluation Scftware, the Evaluaticn Scftware may contain Pre-Release Materials.
ipient herel 2nds, acknowle at: } 2 1 rials not be fully tested and may contain bugs errors; (ii) Pre-Release materials

JlDtP y 3pprovals feor Pre-Raleasa Matarials (such as UL Lk) have not ,eeﬂ obtained, 2nd Pr

rorments or m3y not de suitablc for cort licaticas ard (iv) BIPS can provid

a production version cf the Pre-Ralease Materials . g ; act under ary cblig: “xcn to develop and

Pre-Release Materials and may unllutemily elect to abandon the Pre-Release Materials or any suc
ity whatscever to Recipient or any othep pers

ANY PRE-RELEASE MATERIALS ARE NGN-QUALIFIED AND, AS S R ED D AS AVAILABLE, POSSIBLY WITH FAULTS, AND W NTATICN OR WARRANTY GF ANY KIND.
16.8 Cpan Source S . In the en Source so ft'a"e ncluded with Evaluation Software, such Open Scurce software is licenses pursuant to the applicable Cpen
i S in the an:!icablc ssur(n coda fila{s) J':IGF file hea indicated in the Evaluati

Cpen Scurce software, ncothing in this
t.
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Step 8: Next, you need to set up an Android emulator. Itis responsible for running and testing
the Flutter application.

Step 8.1: To set an Android emulator, go to Android Studio > Tools > Android > AVD Manager
and select Create Virtual Device. Or, go to Help->Find Action->Type Emulator in the search
box. You will get the following screen.

* Andreig Virual Device Manager

Your Vtrtual Bevsces '

Android Stu dto

b test vagat appiic ghien withent havng e

Zreate Wutusl Device

t your agplicetion on, «isiz the

Step 8.2: Choose your device definition and click on Next.
Step 8.3: Select the system image for the latest Android version and click on Next.

Step 8.4: Now, verify the all AVD configuration. If it is correct, click on Finish. The following
screen appears.

Your Virtual Devtces

Ardroxd Stodin

reicon pointed into the red color rectangle. The Android emulator

fz"'"m-m«;
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displayed as below screen.

Step 9: Now, install Flutter and Dart plugin for building Flutter application in Android Studio.
These plugins provide a template to create a Flutter application, give an option to run and
debug Flutter application in the Android Studio itself. Do the following steps to install these

plugins.
‘ Step 9.1: Open the Android Studio and then go to File->Settings->Plugins.

Step 9.2: Now, search the Flutter plugin. If found, select Flutter plugin and click install. When
you click on install, it will ask you to install Dart plugin as below screen. Click yes to proceed.

Flugn Cependencizs Cetected

£ %, . - . ’ - N N '3
1% The plugin you went te install reguires other plugin {Carth which heve to be nslalied st well
L il

Step 9.3: Restart the Android Studio.
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B) Creating Hello World App in Flutter:

Step 1: Create the app

1. Open the IDE and select Create New Flutter Project.

o

Select Flutter Application as the project type. Then click Next.

98]

Verify the Flutter SDK path specifies the SDK"s location (select Install SDK... if
thetext field is blank).

4. Enter a project name (for example, myapp). Then click Next.

Click Finish.

W

6. Wait for Android Studio to install the SDK and create the project.

Step 2: Run the app
I. Locate the main Android Studio toolbar:
Run with coverage  Attach
! |
' '
" iPhcne XS Max .. ‘nain.dart : F
: q |
i A i 1 i i
l i
Target selector Config selector Run  Debug Hot reload Stop

- Inthe target selector, select an Android device for running the app. If none are
listed asavailable, select Tools > AVD Manager and create one there.
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3. Click the runicon in the toolbar, or invoke the menu item Run > Run.

d

froject v

o 7 it

is 3 starting

te get you

; which offers
& Tull API referenc

i
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Step 3 : Creating Hello world app
1. Replace the contents of lib/main.dart. - Delete all of the code from lib/main.dart.
2. Replace with the following code, which displays “Hello World” in the center of
thescreen.

import
'package:flutter/material.dart’;
void main() {

runApp(const MyApp());

}

. class MyApp extends StatelessWidget {
const MyApp({Key? key}) : super(key:
key);@override
Widget build(BuildContext context)

{return MaterialApp(
title: Welcome tu
Flutter’,home: Scaffold(
appBar: AppBar(
title: const Text('Welcome to Flutter'),

® )

body: const Center(
child: Text('Hello World"),
)
),

S
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3. Run the app by selecting Run>Run ,main.dart" and see the output in emulator device.
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OUTPUT:

S v RUTTER APRLICATIONY
2103 BE dart 2oof

cntext) {

@

> ouTUNE
> THAEUME
> DEPERDENCES

CONCLUSION:

We successfully Installed Flutter Environment and Created Hello World App




